Skip to main content

Topic: Latest windows update fucked up the game (Read 1013 times) previous topic - next topic

  • raxx
  • [*]
Latest windows update fucked up the game
Can't alt tab, game freezes, black screen, and alot more stuttering / fps drops.
All after the latest windows upgrade

Almost unplayable.

Anyone else?

Re: Latest windows update fucked up the game
Reply #1
Yes.

Something changed the way darkfall treats alt-tab the last month - 2 weeks'ish. I'm not sure if it's Windows 10 for the latest Nvidia driver but something is stopping Darkfall from being allowed to alt-tab to the background.

It's hard to tell because I also have a Razer Mouse and their app is so f****** dogshit I wonder if that hasn't screwed something up

Re: Latest windows update fucked up the game
Reply #2
Many people have said its the most recent windows 10 update and you need to revert it to fix.

Re: Latest windows update fucked up the game
Reply #3
Definitely the same. I can still alt tab, but now at times when I tab back in, my FPS drops to a consistent 30-40.  Also, load lag is INSANE now. If I come across a chaos chest I'm half convinced it's a dang siege force.

Re: Latest windows update fucked up the game
Reply #4
I'm guessing it's the new "gaming features" that are expanded on windows 10 lately. I'll post where it's located, but they have added almost like a UI feature set similar to nvidia that overlays everything when you are gaming

Re: Latest windows update fucked up the game
Reply #5
Right click lobby.exe and disable fullscreen optimization or roll back the Win 10 update

Also go into  Windows settings, Game - Xbox or Game DVR and disable it.
  • Last Edit: May 20, 2018, 03:36:25 am by Nataz

  • mrW
  • [*][*][*][*][*]
Re: Latest windows update fucked up the game
Reply #6
I'm guessing it's the new "gaming features" that are expanded on windows 10 lately. I'll post where it's located, but they have added almost like a UI feature set similar to nvidia that overlays everything when you are gaming
You can disable that feature altogether. Doing it did give me 15-20fps increase when I played.

Quote
"Our title system is an expansion of the titles in the same spirit than the destroyer title. These will NOT be classes and will be completely optional."

  • gosti
  • [*][*][*][*][*]
Re: Latest windows update fucked up the game
Reply #7
Right click lobby.exe and disable fullscreen optimization or roll back the Win 10 update

Also go into  Windows settings, Game - Xbox or Game DVR and disable it.

This.

Re: Latest windows update fucked up the game
Reply #8
No problems here. Playing in (borderless) windowed mode though.

Re: Latest windows update fucked up the game
Reply #9
Right click lobby.exe and disable fullscreen optimization or roll back the Win 10 update

Also go into  Windows settings, Game - Xbox or Game DVR and disable it.
i did it but it doesn't work for me anyway :-(

Re: Latest windows update fucked up the game
Reply #10
1) Disable "Focus Assist" (new feature that came with April update); be sure to disable all options
2) Disable or uninstall Game DVR / Xbox app
3) Right click DF shortcut, properties > compatibility:



And big thanks to @Nataz for 3)
  • Last Edit: June 16, 2018, 10:34:25 am by Wyverex
Wyverex Erisian, SG of Scrubs


Still a member of SaltyBitches™ Club

Re: Latest windows update fucked up the game
Reply #11
And big thanks to @Nataz for 3)
Ahh thx, i couldn't find that full screen optimization to inactivate, I disabled the rest but wasn't finding it. I will try again now with those 2 ticked

Re: Latest windows update fucked up the game
Reply #12
No problems here. Playing in (borderless) windowed mode though.
Fascinating
dodgy bastard

Re: Latest windows update fucked up the game
Reply #13
Disabling fullscreen optimizations fixed it for me

  • msilvers73
  • [*]
Re: Latest windows update fucked up the game
Reply #14
1) Disable "Focus Assist" (new update that came with April update)
2) Disable or uninstall Game DVR / Xbox app
3) Right click DF shortcut, properties > compatibility:



And big thanks to @Nataz for 3)

Thank you so much @Wyverex ! I have known about the disable video optimization for awhile, which allowed me to be able to switch screens, but for w.e reason it would take FOREVER to switch between 2 games. (alt+tab). But turning of the focus settings worked! You the man!

So in essence guys
1. For good fps- Disable dvr
2.- If you CANT switch screens turn off video optimization
3.- If you can switch screens, but it takes forever (longer then before the update), turn off every focus setting.
  • Last Edit: June 10, 2018, 09:13:49 am by msilvers73
Newbie at play - beware of progress.

The will to succeed will surely surpass your experience.